Please! Help with Galaxy S7 flashing Stock rom after root, only download mode works n

Hello I am New Here on this forum so please forgive me if I posted this in the wrong place.

My problem is that I probably bricked My phone and cant Marke IT work again. I have a Samsung Galaxy S7 (Exynos, European model) and rooted it right after i bought it.
I flashed TWRP recovery, installed Titanium backup and Magisk.
Then I made Nandroid backup using TWRP, stored IT on an external sd card in the phone, also flashed this backup to see if IT works, nad everything worden out just fine.
Then I also made a backup of all system and user apps via Titanium backup. And after that began to delete the bloatware. First uninstalled Microsoft word and rebooted, still everything alright. Then uninstalled excel, rebooted also still everything worked fine. Then I decided to check if I can really restore those system apps and restored the previous nandroid backup with TWRP.
After IT finished it said no os installed are you sure you wish to reboot. And I was so dumb to reboot the phone.
It went to Samsung Galaxy logo then and the only thing I can do now is to go Into download mode.
I want to Flash stock Rom from Samsung now but my Windows 7 does not recognize the phone.I Tried with different usb cables, installed the Samsung drivers multiple Times but it still wont recognize it. I also dont know my phones imei and all those numbers i can only go Into download mode nothing else. And I threw that little sticker on the back of my phone away, searched for it in the trash twice and everything from my phone unboxing is there but THIS ONE is not there, its just not there. So i can also Do nothing with smart switch and such.
I have Odin on my Computer( which i also used to Root) but I cant flash anything in download mode as long as that f*cking computer won't recognize the phone.
And I also think that i might NOT have enabled USB debugging. Im not sure but it might be. I dont know how to do this externally without having access to my phone. And also wehen I leave download mode and try to boot into the normal system it Shows that battery that always shows up when you charge your phone, but it stays gray and seems not to charge at all.

Sorry for the long text but i am really desperate. I have no money at all to buy a new phone and I really need a phone with Access to Internet. Its basically a life or death situation, I need to get out of the place I am as in right now as fast as possible so I must make the device running again!!! I can't eben be sure if what im writing here is not being monitored.
So please I would appreciate any help that makes me save my phone, please help me!

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by anibal07
3 hours ago
Last post by quitzon.marietta
1 hour ago
Last post by amiya.jast
2 hours ago
Last post by rohan.lindsay
4 hours ago
Last post by awalter
25 minutes ago
Last post by carolina70
4 hours ago
Last post by kohler.stefanie
40 minutes ago